Prisma 1 Forum

Having issues with Prisma deploy

When I use prisma deploy, I get this error: Cluster secret in env var PRISMA_MANAGEMENT_API_SECRET does not match for cluster default

version - prisma/1.22.0-beta.8 (windows-x64) node-v11.0.0


Firstly can you double check the secrets you are using are correct and matches the docker-compose file you are using.

If that still doesn’t help you this maybe related to this issue So can you please try this again on the latest beta where this has been fixed.

It will be great if you can provide us a sort of reproduction of this issue so that we may get to the root cause of it if this doesn’t resolve your issue.

Let me know if you get any further trouble :slightly_smiling_face:

Hey @Scott, did you set the PRISMA_MANAGEMENT_API_SECRET environment variable in the first place before running prisma deploy? You can find out more about this topic in the docs:

1 Like

I encountered the same error after I deployed a GraphQL server to Heroku and then went to deploy my prisma service to the same url, so I updated the managementApiSecret in my docker compose, ran docker-compose again, and set the PRISMA_MANAGEMENT_API_SECRET. Now I get a Cannot POST /management error - is there a more recent issue?